Tips n Trik Timer di Mikrotik

 

Misalnya IP Address klien yang telah kita set dan kita berikan src-nat IP publik (diasumsikan tidak melewati proxy) di Mikrotik adalah : 172.168.1.0/30

1. Login ke Mikrotik OS Anda, lalu ketik :

system script

2. Ketik script untuk mematikan koneksi pelanggan ke arah publik:

add name=”pelanggan-off” \
policy=ftp,read,write,policy,winbox,password \
source={/ip firewall nat set [/ip firewall nat find \
src-address=172.168.1.0/30] disabled=yes}

3. Sedangkan script untuk menghidupkan koneksi pelanggan ke arah publik:

add name=”pelanggan-on” \
policy=ftp,read,write,policy,winbox,password \
source={/ip firewall nat set [/ip firewall nat find \
src-address=172.168.1.0/30] disabled=no}

4. Lalu, langkah terakhir adalah menentukan jam kapan pelanggan harus terkoneksi ke publik (internet) atau mematikan IP publik pelanggan yang telah kita masukan kedalam script tadi. Misalnya kita tentukan jam hidup koneksi pada pukul 09.00 -14.30, sedangkan waktu matinya koneksi pada pukul 14.31 – 08.59. Cukup kita panggil nama scriptnya didalam schedule :

.. scheduler

add name=hidup09-1430 start-time=09:00:00 \
interval=1d on-event=pelanggan-on

add name=mati1431-0859 start-time=14:31:00 \
interval=1d on-event=pelanggan-off

———————————————oo————————————

Metode lainnya, secara teori (halah) dapat dilakukan dengan gagasan seperti:

Set di Interface Local atau Interface yang digunakan sebagai gateway oleh Client kita, dengan Status ARP nya Reply Only. Selanjutnya IP ARP List kita statiskan. Nah, dengan modus seperti itu hanya client yang terdaftar MAC Address dan IP Addressnyalah yang dapat lewat koneksi Internetnya. Jadi dapat juga dengan membuat script untuk mendisable dan mengenable pada IP ARP List, selanjutnya dibikin skedulnya pada Scheduler.

Set pada Queue, apakah itu Queue Simple atau Queue Tree, dengan mengecilkan besar Trafik Packet yang lewat, misalkan diberi saja sebesar 8kb. Sedangkan untuk jam normalnya diset ke besar packet awal. Jadi koneksinya seperti “tercekek”

Set di IP Firewall Filter Rules berikan chain Input utk IP address pelanggan tersebut, kalau perlu set port apa saja yang diberikan, selanjutnya berikan Action Drop, kalau ingin lewat lagi trafiknya tentu saja di ACCEPT pada bagian Action. Perhatikan, Mikrotik sepertinya membaca rule secara berurutan dari atas ke bawah, seperti Interpreter lah kalau dalam programming languange. Jadi Rule yang di Drop diatur posisinya dibagian atas dari rule selain Actionnya Drop.

Metode mana yang efektif, sepertinya perlu dicoba juga, hehehe.

Silahkan di coba, tapi jangan di salah gunakan.

This entry was posted in MikroTik and tagged . Bookmark the permalink.

Leave a Reply

Please log in using one of these methods to post your comment:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s